[NeXus-tech] [NeXusDefinitions] #25: Review: NXfermi_chopper
Pete Jemian
prjemian at gmail.com
Mon Dec 22 17:52:38 GMT 2008
Now this goes to a global question:
Do we want/need to have a units attribute for any "field" declaration
with a "type" that is a member of NX_NUMBER?
If so, then we satisfy this part of the ticket (but use NX_UNITLESS
instead).
Plus we change all other NXDL similarly.
NX_DIMENSIONLESS
for fields where the units cancel out, example: "" or mm/mm
NX_UNITLESS
for fields that don't have a unit (e.g. hkl) so that they don't
inherit the wrong units
NeXus Base Classes and Instrument Definitions wrote:
> #25: Review: NXfermi_chopper
> ----------------------------+-----------------------------------------------
> Reporter: Stuart Campbell | Owner:
> Type: defect | Status: new
> Priority: major | Resolution:
> Keywords: |
> ----------------------------+-----------------------------------------------
> Old description:
>
>
>> * Rename "num" to "number".[[BR]]
>> * Rename NX_DIMENSIONLESS to "number" field.
>>
>
> New description:
>
> * Rename "num" to "number".[[BR]]
> * Add NX_DIMENSIONLESS units to "number" field.
>
>
--
----------------------------------------------------------
Pete R. Jemian, Ph.D. <jemian at anl.gov>
Beam line Controls and Data Acquisition, Group Leader
Advanced Photon Source, Argonne National Laboratory
Argonne, IL 60439 630 - 252 - 3189
-----------------------------------------------------------
Education is the one thing for which people
are willing to pay yet not receive.
-----------------------------------------------------------
More information about the NeXus-tech
mailing list