[NeXus-tech] Units in nxdl

Akeroyd, FA (Freddie) freddie.akeroyd at stfc.ac.uk
Wed Nov 19 18:11:21 GMT 2008


Greetings! I'm now back from Oz and catching up on things (including the meeting minutes). I think it has proved to be a very positive NIAC meeting and I see much good work has been continuing on NXDL.

To make keeping track and a record of discussions easier, could we use the nexus-tech at nexusformat.org list for future emails - I've now added Pete Jemian to the list (everybody else was already on it).

Just a quick comment on units - I think it would be a good idea to prefix our names i.e. use

NX_UNITS_LENGTH
NX_UNITS_ANY

Etc.

This makes it clearer what the names stand for and would allow unit names to be easily matched by a regular expression, if needed, at a later point. 

Freddie

-----Original Message-----
From: Peterson, Peter F. (pf9) [mailto:petersonpf at ornl.gov] 
Sent: 18 November 2008 14:17
To: Pete Jemian
Cc: Campbell, Stuart I. (scu); Mark Koennecke; Akeroyd, FA (Freddie); Nick Hauser
Subject: Re: Units in nxdl

Now what is left is "clock_pulses", "g cm-3", "cm -2", and "MW". I also
created "NX_ANY" for things like logs that aren't picky on units.

P^2


On 11/17/08 6:34 PM, "Pete Jemian" <prjemian at gmail.com> wrote:

> 
> I have a few suggestions and some empty slots.
> 
> Peterson, Peter F. (pf9) wrote:
>> I have restricted the value of the units attribute in the definitions.
>> It is currently being left as an attribute so the collapsed view of
>> the document is still easy to read. The ones that take more than five
>> seconds to figure out are:
>> 
>>     * Nxcrystal ­ Angstroms3, Angstrom^-1, arc_minutes
>> 
> Angstroms3 : NX_ATOMIC_VOLUME
> Angstroms^-1 : NX_WAVENUMBER (see the Wikipedia entry for confirmation)
> arc_minutes : NX_ANGLE
>> 
>>    *
>> 
>> 
>>     * Nxdetector ­ clock_pulses, steradians, ³²
>> 
> clock_pulses :
> steradians : NX_SOLID_ANGLE
> "" : NX_DIMENSIONLESS
>> 
>>    *
>> 
>> 
>>     * There are several places that phase occur (insertion devices and
>>       choppers)
>> 
> phase :
>> 
>>    *
>> 
>> 
>>     * Several fields have blank units because anything can be used.
>> 
> propose changing name of
> "anyUnitsAttr"
> to
> "NX_anyValidNxUnitsAttr"
>> 
>>    *
>> 
>> 
>> 
>> P^2 

-- 
Scanned by iCritical.



More information about the NeXus-tech mailing list